SELFHTML:Forum/neues Forumsdesign (2013)

Aus SELFHTML-Wiki
Wechseln zu: Navigation, Suche

Anmerkungen, Hinweise und Kritik zum neuen Forumsdesign[Bearbeiten]

Bugliste[Bearbeiten]

SELFHTML:Aktuelle Ereignisse/neues Forumsdesign/Bugliste (readonly)

Filter-Bug[Bearbeiten]

Sowohl der Themen- wie auch der Live-Filter haben das Attribut name="lf". Dadurch wird ein Filterstring nicht mehr ins Input-Feld des Live-Filters übernommen. Der Live-Filter "erzeugt" beim Reload eine URL wie bspw "http://forum.de.selfhtml.org/my/?lf=author%3Dfoobar". Hier müßte foobar im Input-Feld des Livefilters stehen, aber da offenbar vom Browser das letzte vorkommende Element gewählt wird (Themenfilter-Select) scheitert dies. Anscheinend muß das Input-Element im Dokument hinter dem Themen-Filter liegen.

In die Bugliste eingetragen -- Matthias 08:30, 30. Jan. 2013 (CET) --
das ist dort aber leider anders (anderes Verhalten) beschrieben als ich meinte.
Vielleicht habe ich mich auch unglücklich ausgedrückt:
Im Themenfilter wird „Sonstiges“ eingestellt.
Im Eingeabefeld des Live-Filters muss dann „category = "Sonstiges"“ stehen.
richtig verstanden?
-- Matthias 12:39, 30. Jan. 2013 (CET) --
Leider nicht. Es geht ausschließlich um die Befüllung des Live-Filters. Wenn ich dort einen Suchausdruck eingebe, dann soll genau dieser Suchausdruck nach dem Drücken des Buttons "Filtern" weiterhin im Livefilter-Eingabefeld stehen, wie es bisher auch immer der Fall war. Stattdessen ist jetzt das Feld danach leer. Das ist lästig, wenn man längere und kombinierte Filter leicht modifiziert mehrfach anwenden will.
Bei Formularen ist es üblicherweise so, daß Werte aus einem Query-String einem Formular-Element zugewiesen werden, bspw. bei http://google.de?q=irgendwas wird der Wert „irgendwas“ ins Feld mit dem Namen „q“ übernommen. Bisher war das auch beim Live-Filter ähnlich, „?lf=suchterm“ befüllte das Livefilter-Eingabefeld mit „suchterm“.
Meine Vermutung: Da im neuen Markup aber der Themenfilter mit dem gleichen „name“-Attribut im Dokument hinter dem Live-Filter angeordnet ist (im alten Forum war es umgekehrt), wird der Wert aus dem Query-String vom Browser nicht mehr dem Livefilter-Eingabe-Element zugewiesen, sondern dem Themenfilter weil der Browser offenbar versucht, immer das letzte Element eines bestimmten Namens zu wählen, falls mehrere vorhanden sind. Dies scheitert natürlich, da nun dieses Element nicht wie früher ein input-Element ist, sondern nun ein select_Element --87.161.1.151 13:11, 30. Jan. 2013 (CET)
Ja, das schließt mein beschriebenes Verhalten ein und einen Lösungsansatz hast du auch mitgeliefert. -- Matthias 13:21, 30. Jan. 2013 (CET) --
Wie gesagt, es ist erst einmal eine Vermutung. Muß also erst einmal getestet werden, ob es wirklich so funktioniert, wie ich es mir vorstelle, wenn die Reihenfolge geändert wurde. Kann auch etwas ganz Anderes sein, ich weiß ja nicht, was ihr alles geändert habt.--87.161.1.151 16:12, 30. Jan. 2013 (CET)
Lag nicht an der Reihenfolge. Trotzdem fixed. -- Matthias 16:26, 30. Jan. 2013 (CET)

Fehler bei der Markierung beim "Filtere nach Autor"[Bearbeiten]

Wenn man das Forum nach einem Autor filtert, wird der Beitrag nur markiert (gelb hinterlegt), wenn vor dem Beitrag in der "nested"-Ansicht kein Pfeil ist. --

Ich kann das leider nicht nachvollziehen. Könntest du genauer beschreiben, wie du gefiltert hast, wo die gelbe Hinterlegung herkommt, ... Danke -- Matthias 21:17, 10. Feb. 2013 (CET) --
Ich klicke auf den Autorennamen und wähle "Filtere nach Autor". Die gelbe Hinterlegung kommt, wie schon im alten Design, "vom Forum". Ich habe da (bewusst) nichts eingestellt. Ich schick dir aber per Mail meinen Accountnamen.
fixed -- 31.212.197.117 22:15, 11. Feb. 2013 (CET) --

Tipps und Tricks für das User-CSS[Bearbeiten]

SELFHTML:Forum/Tipps_und_Tricks

Änderungswünsche[Bearbeiten]

Listenpunkte für Sortierung der Threads[Bearbeiten]

Es braucht meiner Meinung nach keine Bulletpoints vor den Radiobuttons...

Kannst du das etwas spezifizieren? Ich weiß grad nicht, wo du bist. Dort, wo ich meine, gibts keine bullets. -- Matthias 09:58, 26. Jan. 2013 (CET)--

Forumskopf: Links im Text nicht erkennbar[Bearbeiten]

Daß in dem Satz "Dieses Forum versteht sich sowohl als Ergänzung zum SELFHTML-Wiki als auch zur statischen Dokumentation SELFHTML." zwei Links stecken, erkennt man leider nur, wenn man mit der Maus über die Links fährt - und auch da nur an der Cursor-Form.

Gleiches gilt für den Kasten "Anmerkungen, Hinweise und Kritik zu diesem Forumsdesign bitte im SELFHTML-Wiki eintragen." - daß "SELFHTML-Wiki" verlinkt ist, ist nicht zu sehen.

(Firefox 18.0.1 auf Windows XP)

Es gab viel für und wider um das Unterstreichen der Links. siehe SELFHTML:Forum/Tipps_und_Tricks#Links_unterstreichen -- Matthias 10:03, 26. Jan. 2013 (CET) --
Unterstreichen muß ja gar nicht sein. Nur irgendwie vom Fließtext unterscheidbar sollten sie sein (Farbe?). Und das man die erst erkennen kann, wenn man sich ein eigenes CSS bastelt, halte ich für sehr fragwürdig. Da würde ich eher umgekehrt vorgehen - Links hervorheben, und einen Tipp geben, wie man die Hervorhebung unterdrücken kann. Denn wenn man gar nicht sieht, daß da ein Link ist, weiß man ja gar nicht, daß man etwas hervorheben könnte.
Eine andere Farbe haben sie. -- Matthias 11:20, 26. Jan. 2013 (CET) --
AH. Dann ist das jetzt anders als bisher - die in den Benutzereinstellungen angegebene Schriftfarbe gilt jetzt auch für Links. Nachdem ich dort #000 entfernt habe, ist die Schrift immer noch schwarz, und die Links sind blau.
Dann ändere ich halt die 'Beschwerde' in "die in den Benutzereinstellungen angegebene Schriftfarbe sollte nicht die Farbe der Links überschreiben" ;-)
Der Selektor, der in ein Stylelement geschrieben wird (und auch früher wurde), heißt
body, h1, h2, h3, p, ul, ol, dl, div, th, td, a:link, a:visited, a:active, #antwortformular textarea
auf welche Elemente sollte denn deiner Meinung nach die Festlegung einer Schriftfarbe zutreffen?
Ich meine, das könnte im Forum diskutiert werden
-- Matthias 16:18, 26. Jan. 2013 (CET) --
eingetragen -- Matthias 13:22, 26. Jan. 2013 (CET) --
fixed -- Matthias 17:35, 30. Jan. 2013 (CET) --

Posting wird in Monospace angezeigt (richtig), Antwortfenster wird mit Proportionalschrift angezeigt (falsch)[Bearbeiten]

Beide Bereiche sollten gleich (und m.E. in Monospace) angezeigt werden.

Kann ich nicht nachvollziehen. Bitte genauer beschreiben. Es sind (sollten) beide in monspace formatiert (sein). -- Matthias 10:06, 26. Jan. 2013 (CET) --
Screenshot - oben Mono, unten Proportional
So siehts bei mir aus Die Zitatzeichen zeigen mir, dass du in der benutzerspezifischen Ansicht bist. Möglicherweise irgendeine Einstellung? -- Matthias 10:25, 26. Jan. 2013 (CET) --
Ja - ich habe von Schriftart Standard auf Arial umgestellt. Bei Standardschrift reagiert die Schrift nicht auf die in Benutzereinstellungen angegebene Schriftgröße und bleibt auch bei z.B. 20px winzig klein. Stell ich Arial um, reagiert die Schrift auf die von mir angegebene Schriftgröße (- 10%, siehe andere Meldung). Aber dann wird die textarea auch Arial. Das Posting selbst bleibt bei Courier.
Scheint also generell so zu sein, daß die Benutzereinstellungen nicht mehr richtig funktionieren.
fixed (für neue-Beitragsseite gelten derzeit keinerlei Benutzerangaben [1]) -- Matthias 23:51, 30. Jan. 2013 (CET) --

Schriftgröße aus Benutzereinstellungen wird nicht korrekt beachtet[Bearbeiten]

Ich geben 15px in den Benutzereinstellungen vor. Laut Firebug ist für die Texte, Postingsüberschriften usw. auf der Hauptseite die Computed font-size 13.4833px. Bei 20px Vorgabe kommen 17.8...px raus. Also jeweils gut 10% Schwund. In der Einzel-Posting-Ansicht ist die Schrift ebenfalls kleiner als in den Benutzereinstellungen vorgegeben.

(Firefox 18.0.1 auf Windows XP)

muss geprüft werden. -- Matthias 10:08, 26. Jan. 2013 (CET) --
fixed -- Matthias 23:52, 30. Jan. 2013 (CET) --

Pfeil vor Ursprungsposting überlagert Kategorie[Bearbeiten]

siehe screenshot (User-CSS + User-JS sind deaktiviert) (Firefox 18.0.1 auf Windows XP)

Ist bei mir auch in der unangemeldeten Ansicht nicht so . Dort sollte weder Pfeil noch Linie sein. -- Matthias 10:12, 26. Jan. 2013 (CET) --
Bei hervorgehobenen Kategorien fehlt der Pfeil.
siehe Bei CSS Pfeil, bei Projektverwaltung Pfeil
wie gesagt: Auch in diesem Ausschnitt sollte gar kein Pfeil zu sehen sein. Vergleich so sollte es sein -- Matthias 10:30, 26. Jan. 2013 (CET) --
Zeile 457ff in forum-blau.css?4 enthält .posting { background: url("http://src.selfhtml.org/forum/posting-pfeil1.png") no-repeat scroll left bottom transparent; }
Der HTML-Code enthält: <span class="posting">, auch für das Root-Element.
==> der Pfeil ist da (und muß es vom Code her auch sein)
Der Pfeil wird ausgeblendet durch .answers + .posting, .answers-closed + .posting. Wenn du jetzt die Antworten ausblendest, greift der Selektor nicht, weil für das CSS "display:none" wie nicht vorhanden ist.
Ich weiß grad nicht, ob diese Erklärung korrekt ist, aber es scheint so zu sein.
Du könntest die Antworten ausblenden über visiblity: hidden; width: 0;
-- Matthias 13:40, 26. Jan. 2013 (CET) --
Die Pfeile überlagern die Kategorie unabhängig davon, ob Antworten vorhanden, eingeblendet oder ausgeblendet (Thread komplett gelesen) sind. Der Pfeil ist unterdrückt, wenn die Kategorie (über die Benutzereinstellungen) hervorgehoben ist (aber nur dadurch, daß die Hervorhebungshintergrundfarbe den Pfeil überdeckt).
In der Thread-Ansicht im Einzelposting wird korrekt der "oberste" Pfeil unterdrückt. Das "Problem" betrifft also nur die Hauptseite.
Damit .answers + .posting greifen könnte, müßte .posting ein Geschwister von .answers sein. .posting ist aber einziges Kind von span class="scoring-color" (welches ein Geschwister von .answers ist.
Ich hab jetzt mal das Scoring deaktiviert. Und schon ist das .posting-span ein Geschwister (und kein Neffe mehr) vom .answers-span. Und damit ist auch der störende Pfeil weg.
also ein weiterer Fall, bei dem die Benutzereinstellungen mit dem neuen Design inkompatibel sind.
.answers + .scoring-color > .posting als zusätzlicher Selektor für's Ausblenden könnte helfen.
So, .scoring-color belegt nun kein eigenes span-Element mehr. Die Information ist, wenn vorhanden, mit in das .posting-span gewandert. Das Pfeil-Problem sollte damit keins mehr sein. Hab ich dabei noch was anderes kaputt gemacht? --dedlfix 23:12, 28. Jan. 2013 (CET)

Code im Posting nicht im Rahmen, keine Scrollbalken[Bearbeiten]

Kann man den Rahmen mit Scrollbalken um Code entfernen bzw. entfernbar machen?

siehe SELFHTML:Forum/Tipps und Tricks#längere Codeauszüge nicht hervorheben -- Matthias 09:15, 24. Jan. 2013 (CET) --

Herauslösen des "Neues-Posting-Buttons" aus seiner HTML-Struktur[Bearbeiten]

Schon im alten Forumsdesign fand ich es unlogisch, dass der Link zum Erstellen eines neuen Threads im mittleren Block bei den Links zu den aktuellen bzw. den archivierten Postings steht. Es ist m.E. logischer, diesen Link in der Box mit "Alle als gelesen markieren", "Ausgeblendete Threads" und "Benutzereinstellungen" zu plazieren. Denn dort stehen die Links, die tatsächlich (indirekt) eine Aktion auslösen, und nicht nur passiv ein Ziel anspringen. Und dann würde ich diesen Block auch nicht mehr mit "Optionen" überschreiben, sondern eher mit "Funktionen". -<mk>

Gute Argumentation. --Performer 10:25, 19. Jan. 2013 (CET)

erledigt -- Matthias 09:15, 24. Jan. 2013 (CET) --

graphische Veranschaulichung der Postinghierarchie[Bearbeiten]

Zur Not eben für jedes Posting -- Matthias 19:45, 18. Jan. 2013 (CET) --

erledigt -- Matthias 09:15, 24. Jan. 2013 (CET) --

Transitions nur auf ein paar Elemente anwenden[Bearbeiten]

Durch den *, :hover selector für die Transitions kommt es zu ungewollten Nebeneffekten, etwa dem langsamen hochrutschen des Inhalts wegen position:fixed auf #top. Hier wäre es sinnvoll die Transitions nur auf z. B. a, a:hover anzuwenden.

siehe SELFHTML:Forum/Tipps und Tricks#Alle Animationen abschalten -- Matthias 09:15, 24. Jan. 2013 (CET) --
damit bleibt es für unregistrierte Nutzer ein zähes Stylesheet siehe auch Forenbeitrag Encoder und Forenbeitrag Kai345
fixed -- Matthias 18:38, 26. Jan. 2013 (CET) --

Sprungmarken Benutzer-Einstellungen[Bearbeiten]

Durch den ständig sichtbaren oberen Balken liegen die Sprungmarken der einzelnen Sektionen in den Benutzer-Einstellungen jetzt unterhalb des Balkens, man muß teilweise wieder ein Stück hochscrollen, um die Bedienelemente zu erreichen. Durch ein padding-top in der Höhe des Balken ließe sich dies vermeiden.

wird gefixt -- Matthias 09:33, 21. Jan. 2013 (CET) --
erledigt -- Matthias 09:15, 24. Jan. 2013 (CET) --

Ist dieser Balken denn überhaupt notwendig oder sinnvoll? Die darin enthaltenen Links zum Forum, zum Wiki und zur SELFHTML-Doku stehen sowieso im Kopfbereich des Forums, ebenso ein Link zur Forums- und Archivsuche. Der einzige Mehrwert ist also der Link zum Blog - und den könnte man IMO auch platzsparender im Kopf des Forums unterbringen. <mk>


Variable Breite des Posting-Textes in Thread-Ansicht[Bearbeiten]

Zur Gewährleistung von Barrierearmut sollte der Lesebereich von Postings keine feste oder Minimalbreite haben sondern variabel sein, damit Sehbehinderte über die Zoomfunktion des Browsers die Schrift vergrößern können ohne horizontal scrollen zu müssen.

In der nested-Ansicht führt das wohl zu Problemen, in der Thread-Ansicht sollte es aber geändert werden.

siehe: Posting im Forum
erledigt -- Matthias 23:08, 25. Jan. 2013 (CET) --

Bilder im Posting bekommen Rahmen[Bearbeiten]

[2]

erledigt -- Matthias 18:39, 26. Jan. 2013 (CET) --

Buttons statt Checkboxen für die neue Nachricht[Bearbeiten]

[3]

erledigt -- Matthias 10:00, 27. Jan. 2013 (CET) --

Javascript für Frameset-Klasse[Bearbeiten]

Das am Ende eingefügte Javascript

document.getElementsByTagName("body")[0].className = "framed";

berücksichtigt nicht, daß bereits Klassen für body gesetzt sein können und überschreibt diese. Besser wäre

document.getElementsByTagName("body")[0].className += " framed";
fixed -- Matthias 18:45, 26. Jan. 2013 (CET) --

Informationsverlust in der Beitrags-Ansicht[Bearbeiten]

es fehlen die angaben für posting-zeitpunkt und anzahl der hilfreich-bewertungen

  • bisher: Die folgende Nachricht zum Thema stammt von: xyz, 12. Februar 2077, 22:47
  • nun: Der folgende Beitrag stammt von xyz.

man muß nun jedesmal runterscrollen und danach wieder hoch um diese info zu erhalten

die anzahl wie oft ein beitrag als hilfreich angesehen wurde ist auch nicht mehr vorhanden.

Wenn es Bewertungen gibt heißt es jetzt: „Der folgende Beitrag stammt von xyz und wurde 7 mal als fachlich hilfreich bewertet“.
Ist denn der Zeitstempel wirklich so wichtig, dass er redundand sein muss?
-- Matthias 17:49, 29. Jan. 2013 (CET) --
danke. trotzdem unschoen, weil dadurch das thema fachliche bewertung weiterhin aufgeteilt ist. das resultat oberhalb der nachricht und die aktion unterhalb.
der zeitstempel ist fuer mich wichtig, um ungefaehr abschaetzen zu koennen wie lange man zeit hat eine antwort zu schreiben ohne das schon zehn andere antworten kommen wenn man fertig ist.
warum wird ueberhaupt am html alles geaendert ohne es dadurch besser zu machen? einiges ist jetzt schlechter als vorher oder fehlt ganz
Mir schwebt eine optische Hervorhebung für fachlich hilfreiche Postings vor. Dann bräuchte man nur noch für die konkrete Zahl nach oben scrollen. Ideen?
Was hältst du von „Der folgende Beitrag wurde am 27. 01. 2013, 17:02 Uhr von User[, Email] veröffentlicht[ und bisher k mal als fachlich hilfreich bewertet].“
Ziel war die oben die Infos, dann das Posting und dann die möglichen Aktionen zu haben
-- Matthias 10:48, 30. Jan. 2013 (CET) --
Zeitstempel wieder drin, CSS-Anpassung folgt. -- Matthias 17:02, 30. Jan. 2013 (CET) --
fixed -- Matthias 23:53, 30. Jan. 2013 (CET) --

Sortierung der Postings für unregistrierte Nutzer[Bearbeiten]

Ich würde es für sinnvoll halten, wenn während eines laufenden Sortiervorgangs ein Hinweis eingeblendet würde, da der Vorgang (insbesondere bei Wahl jüngste Postings oben) je nach Anzahl der Threads und Leistung des Computers durchaus mehrere Sekunden dauern kann. Leider weiß man zur Zeit nicht sicher, ob noch sortiert wird oder der Vorgang beendet ist. Das verleitet zu Mehrfachklicks.

Ansonsten wäre es noch hilfreich, wenn der Link für die gerade geltende Sortierung nicht anwählbar ist oder zumindest gesondert hervorgehoben wird, damit man weiß, welche Sortierfolge zur Zeit aktiv ist.

eingebaut -- Matthias 23:11, 2. Aug. 2013 (CEST) --

Unsortiert[Bearbeiten]

Link zu einer Wiki-Seite Tipps & Tricks für das User-CSS[Bearbeiten]

am besten unter Tipps zum Forum -- Matthias 18:50, 21. Jan. 2013 (CET) --

erledigt -- Matthias 09:15, 24. Jan. 2013 (CET) --